Transmission troubles HELP

If it's about Power Wagons, all generations, this is where it'll go. This is the original PWR Forum Power Wagon Technical Discussion Section. And this includes everything that doesn’t fit in any one of the other categories related to the truck goes here!
Post Reply
POk3s
Posts: 39
Joined: Wed Aug 22, 2018 1:48 pm
Model Year: 2017

Transmission troubles HELP

Post by POk3s » Sun Aug 28, 2022 4:16 pm

Alright guys needing some help before I try and tear into this tomorrow. While driving to Colorado I had a hard downshift with higher RPMs going from 5th to 4th. The transmission then basically stuck in fourth gear. I was scared to stop because I didn't know if the truck would downshift properly. But it wouldn't go to 5th and wouldn't stop to 3rd at highway speeds.

I got to the gas station and everything down shifted fine until I stopped. Turned off truck for a bit and back on the highway everything seemed normal but I kept all that in the back of my mind. Another steep uphill grade in fifth gear and a hard downshift to fourth gear as I tried to pass people caused another lurch in the transmission and this time it beeped and threw a code. So from what little research I can do it looks like maybe some kind of shift solenoid? I'm just hoping the transmission isn't taking a crap on this 2017. I called mechanics as I was stopped in town and of course no one had time to look. I disconnected battery to clear the code and have been more careful since and no real problems minus some hard downshifts but no problems. I'm heading back to Colorado with a trailer in a few days and don't want to leave my trip up to chance...

Plan for now is to change the transmission oil and see how it looks. I'm at 113,000 miles now. Changed it at about 75,000. Attempt to change this solenoid if it's something I feel I can do. Unles you guys have any other advice...good or bad.

For what it's worth, all slow speeds is shifting fine. Even getting on the interstate is shifting fine as long as it's it WOT.

RustyPW
2000_Posts
2000_Posts
Posts: 5224
Joined: Thu May 24, 2012 4:23 pm
Model Year: 2008
Location: Brownsville Pa.

Re: Transmission troubles HELP

Post by RustyPW » Sun Aug 28, 2022 6:48 pm

Sounds like the solenoid pack. Others had the same problem.
PWOC #53
2008 POWER WAGON RC

My build thread. viewtopic.php?f=13&t=2826 :cash: :cash:

Moab '10, '12, '14.
Rausch Creek - Summer '10, Spring-Fall '11, Spring '12, Summer '13, Summer '14, Summer '15, Summer '16, Summer '17, Summer '18, Summer '19 AOAA,

Russ
NRA - Benefactor, Golden Eagle. :lockedandloaded:

POk3s
Posts: 39
Joined: Wed Aug 22, 2018 1:48 pm
Model Year: 2017

Re: Transmission troubles HELP

Post by POk3s » Sun Aug 28, 2022 7:12 pm

Glad to hear you say that as I’m currently researching auto parts places near me. Everyone so far is out of stock of course and can’t have anything here by Tuesday. Looks like I should’ve stayed in Colorado!! Your response does help me with a little more confidence in buying it online so it gets shoved in the mail bright and early tomorrow.

Also, sorry if it’s a repeated question. I tried searching but came up with all sorts of things that didn’t help me.

RustyPW
2000_Posts
2000_Posts
Posts: 5224
Joined: Thu May 24, 2012 4:23 pm
Model Year: 2008
Location: Brownsville Pa.

Re: Transmission troubles HELP

Post by RustyPW » Sun Aug 28, 2022 11:19 pm

If you search. There is a lot of threads on it.
PWOC #53
2008 POWER WAGON RC

My build thread. viewtopic.php?f=13&t=2826 :cash: :cash:

Moab '10, '12, '14.
Rausch Creek - Summer '10, Spring-Fall '11, Spring '12, Summer '13, Summer '14, Summer '15, Summer '16, Summer '17, Summer '18, Summer '19 AOAA,

Russ
NRA - Benefactor, Golden Eagle. :lockedandloaded:

User avatar
Bill2014
1000_Posts
1000_Posts
Posts: 1511
Joined: Fri May 09, 2014 9:03 pm
Model Year: 2014
Location: Northern NY

Re: Transmission troubles HELP

Post by Bill2014 » Mon Aug 29, 2022 10:19 am

As Rusty said, you are not alone...

here's a thread: viewtopic.php?f=39&t=6629
2014 Power Wagon Laramie
Titan V5 2.5" Receiver Pintle Hook
Warn wireless winch controller
.188" DOM White Knuckle Rock Sliders
Locker Bypass & Nanny Kill Switch

Moab 2006

Jmarklowitz
Posts: 39
Joined: Fri Sep 09, 2016 12:14 pm
Model Year: 2016
Location: Centennial, CO

Re: Transmission troubles HELP

Post by Jmarklowitz » Thu Sep 01, 2022 5:15 pm

Wasn't there a recall on the solenoid pack back in the day? I have a 2016 with the 6spd Auto and thought there was some sort of recall performed on my truck. Might look into that too...
2016 Laramie PW

POk3s
Posts: 39
Joined: Wed Aug 22, 2018 1:48 pm
Model Year: 2017

Re: Transmission troubles HELP

Post by POk3s » Sun Oct 02, 2022 3:01 pm

I wanted to update this thread just in case others had the same problem.

Replaced the solenoid pack and took it for a quick test drive. Thought it was fixed and no. Same problems when I started towing.

Threw the code so I stopped into dealership. Was told it was my solenoid, and I mentioned how I had just replaced the solenoid. The mechanic said, you may need a whole new valve body as we just had a truck in here with the same problem, bad pitting in the valve body and it would throw this code. I asked him if he was confident that would solve the problem and he said “If this was my truck, that’s what I’d do.”

So I drove it for a bit trying to baby the truck but it become unbearable. Just changed it and it has fixed the problem. It’s good to be able to drive the truck again!

Anyway, hope this helps somebody at some point!

User avatar
jeep_boy02
1000_Posts
1000_Posts
Posts: 1067
Joined: Sat Feb 16, 2013 1:21 pm

Re: Transmission troubles HELP

Post by jeep_boy02 » Mon Oct 03, 2022 12:15 am

Nice, thanks for heads up and the update

Sent from my SM-G715U1 using Tapatalk

2010 black pearl(PXR) on 35s, bypass harness, gooseneck, CAI, 3" magnaflow catback, bulldog hemi GT.... more to come soon

Post Reply