Service 4WD System flashing

If it's about Power Wagons, all generations, this is where it'll go. This is the original PWR Forum Power Wagon Technical Discussion Section. And this includes everything that doesn’t fit in any one of the other categories related to the truck goes here!
Post Reply
dimrod
Posts: 12
Joined: Sun Mar 20, 2016 10:30 pm
Model Year: 2014

Service 4WD System flashing

Post by dimrod » Fri Sep 10, 2021 4:31 pm

On my 2016 PW, the "Service 4WD System" will message flash every time I place the lever in 4WD. Sometime the ABS light comes on too. The 4WD appears to be functioning as it should. The "4WD Lock" indicator light continuously flashes whether the lever is in the 4Hi position or 2WD position until I turn off the vehicle and restart it in 2WD. The flashing messages and indicators do not reappear until I place the shift lever in 4WD again. My son hooked up a code reader to the vehicle but it showed no codes. 35,000 miles on vehicle.

Where should I start looking for the problem? I live in Western Alaska with no dealer support. Thanks.

User avatar
jeep_boy02
1000_Posts
1000_Posts
Posts: 1021
Joined: Sat Feb 16, 2013 1:21 pm

Re: Service 4WD System flashing

Post by jeep_boy02 » Sat Sep 11, 2021 1:18 am

Most 4wd mils is just the sensor in tcase. Mine came on around 85k miles, pretty simple replacement.

Iirc if your sensor is in a fail state the smart bar won't function correctly but you still will be able to use 4wd, just may not have use of lockers and disco

Sent from my SM-A015A using Tapatalk

2010 black pearl(PXR) on 35s, bypass harness, gooseneck, CAI, 3" magnaflow catback, bulldog hemi GT.... more to come soon

dimrod
Posts: 12
Joined: Sun Mar 20, 2016 10:30 pm
Model Year: 2014

Re: Service 4WD System flashing

Post by dimrod » Sat Sep 11, 2021 3:46 am

Do you know the part number of the sensor?

RustyPW
2000_Posts
2000_Posts
Posts: 5115
Joined: Thu May 24, 2012 4:23 pm
Model Year: 2008
Location: Brownsville Pa.

Re: Service 4WD System flashing

Post by RustyPW » Sat Sep 11, 2021 7:27 pm

Here's a good link. I've used this place a couple of times.

https://www.moparautopartsdirect.com/?code=6004
PWOC #53
2008 POWER WAGON RC

My build thread. viewtopic.php?f=13&t=2826 :cash: :cash:

Moab '10, '12, '14.
Rausch Creek - Summer '10, Spring-Fall '11, Spring '12, Summer '13, Summer '14, Summer '15, Summer '16, Summer '17, Summer '18, Summer '19 AOAA,

Russ
NRA - Benefactor, Golden Eagle. :lockedandloaded:

User avatar
jeep_boy02
1000_Posts
1000_Posts
Posts: 1021
Joined: Sat Feb 16, 2013 1:21 pm

Re: Service 4WD System flashing

Post by jeep_boy02 » Sun Sep 12, 2021 1:27 am

Here ya areImage

Sent from my SM-A015A using Tapatalk

2010 black pearl(PXR) on 35s, bypass harness, gooseneck, CAI, 3" magnaflow catback, bulldog hemi GT.... more to come soon

dimrod
Posts: 12
Joined: Sun Mar 20, 2016 10:30 pm
Model Year: 2014

Re: Service 4WD System flashing

Post by dimrod » Sun Sep 12, 2021 4:07 am

Thanks. I’ll see if that rectifies my problem.

User avatar
Retired BLM Rig
500_Posts
500_Posts
Posts: 972
Joined: Sun Jan 31, 2016 6:51 pm
Model Year: 2008
Location: San Clemente, Ca.

Re: Service 4WD System flashing

Post by Retired BLM Rig » Tue Sep 14, 2021 1:15 am

Generic code readers usually only read "P" codes (powertrain). You would need a pro scan tool to read "C" (chassis) and "B" (body) codes. Some good shops will read codes for free and only charge you if you want further diagnosis.

I agree with the above suggestions. Does it feel like your front axle engages in 4H and 4L? That would indicate that your CAD (center axle disconnect) is working.

Post Reply