Weird shake at idle

Post Reply
BULLITT1204
Posts: 20
Joined: Fri Jan 25, 2019 12:48 pm
Model Year: 2018

Weird shake at idle

Post by BULLITT1204 » Sat Feb 09, 2019 9:18 am

So i have a 2018 and from day 1 i have felt this. Not sure if the MDS works at idle in park but when i start this truck and i let it idle for say a minute it will start to have that minor shake like it has a missfire... rev it let it come back down. Its Smooth then after or around a minute she starts to get that missfire shake.
Almost would seem maybe MDS is turning on in park after she sits for a minute....
I hinestly think the MDS system is stupid for these trucks or the programing is just trash for it. As unless ur on very light throttle it never comes on and never gets used with cruise control

But anyways so has anyone had that issue were they feel a slight miss at idle in park
2018 tradesman power wagon
Omaha orange

13powerwagon
50_Posts
50_Posts
Posts: 80
Joined: Thu Oct 17, 2013 4:58 pm
Model Year: 2013

Re: Weird shake at idle

Post by 13powerwagon » Sat Feb 09, 2019 9:40 pm

My 13 does the same thing and I have the 5.7 with no Mds.
2013 tradesman
Thuren 2” coils, track bar, control arms, 2.5 Kings and axle truss. Carli ball joints, DOR steering brace, AEV salta wheels, 35” nitto ridge grapplers, white knuckle sliders, purple cranium dif covers.

BULLITT1204
Posts: 20
Joined: Fri Jan 25, 2019 12:48 pm
Model Year: 2018

Re: Weird shake at idle

Post by BULLITT1204 » Sun Feb 10, 2019 1:45 am

13powerwagon wrote:
Sat Feb 09, 2019 9:40 pm
My 13 does the same thing and I have the 5.7 with no Mds.
It only concerns me as i feel its not normal ya know. But its done it from day 1 . Even tonight left restaurant warmed truck up for abput 2 minutes and abput 45 sec into it she started this shake/miss feeling... i think im going to see about dealer checking it out on next oil change. Since it always does it hot or cold at idle in park ill have to update this prolly later this month on it
2018 tradesman power wagon
Omaha orange

User avatar
Punishher7
50_Posts
50_Posts
Posts: 53
Joined: Mon Sep 10, 2018 10:25 pm

Weird shake at idle

Post by Punishher7 » Sun Feb 10, 2019 2:04 am

Mine 18 had a similar thing happening when new. Not sure if it went away or if I just don’t notice it anymore... When I inquired about it was told it could be a bad motor mount. Had them checked during a recall and all came back good. Let us know what the dealer finds.


Sent from my iPhone using Tapatalk

FordyceCreekTrail
250_Posts
250_Posts
Posts: 466
Joined: Sun Apr 17, 2016 8:31 pm
Model Year: 2014
Location: Albuquerque

Re: Weird shake at idle

Post by FordyceCreekTrail » Sun Feb 10, 2019 9:40 am

Mine never did that, but had a lot off tapping new. That has gone away. Seems like these engines run smoother after some break in.
2018 Flame Red, Moon Roof, Dual Alternators, Ram Boxes sadly Ram ran out of, Luxo Package with 8.4 UConnect, Enter and Go with remote start, Auto Wipers and Lights. Added missing skids and White Knuckle sliders. 35" BFG KM3s. Procal and Warn wireless remote for winch.

BULLITT1204
Posts: 20
Joined: Fri Jan 25, 2019 12:48 pm
Model Year: 2018

Re: Weird shake at idle

Post by BULLITT1204 » Sun Feb 10, 2019 10:46 am

Yeah i have 9300 miles on it currently i picked it up with 7100 easy miles on it... but thanks it could be the motor mount as well im rusty ive forgotten some things... ill add that to the list of things to check
2018 tradesman power wagon
Omaha orange

vette80
Posts: 4
Joined: Thu Mar 14, 2019 2:26 pm
Model Year: 2018

Re: Weird shake at idle

Post by vette80 » Fri Apr 12, 2019 4:25 pm

Mine did this from day one and as a mechanic I thought the same thing. However there is no misfires out the counter, no check engine light and no performance issues. I did think for a minute that the truck might take premium gas, and i've been using regular. Haven't checked the owners manual yet. Bought mine with 43 miles on it, it has 2200 on it now and I can always feel it, but only at idle.

User avatar
PWJouster
250_Posts
250_Posts
Posts: 280
Joined: Wed Dec 27, 2017 8:44 am
Model Year: 2018

Re: Weird shake at idle

Post by PWJouster » Mon Apr 15, 2019 8:53 am

My 18 , always on premium, will do this as well.

Reminds me of some of my motorcycles when the clutch would start to go bad and when you warp clutches, you get grab in idle in certain designs. Mainly my DR650.

Present in my Hemi 6.2 HC charger as well, and that was an aggressive shake, readily visible in all fluids and towel racks.
2018 Powerwagon-6.4 Hemi
Nanny kill switch and Locker Bypasses
Thuren Tuned King 3.0 & 2.5 Pintop Stage 3/2
17 Method NV-Toyo RT 35
Evo On-Demand Swaybar Disconnect
S&B Intake-Mufflex-Magnaflow/resonator delete
SPOD
On-Board air ARB CKMTA12
Baja design and Rigid Industries
Purple Cranium Spider dif guards
Pedal Commander

User avatar
BoldAdventure
Moderator
Moderator
Posts: 2255
Joined: Fri Mar 25, 2016 11:23 am
Model Year: 2015
Location: Nomadic
Contact:

Re: Weird shake at idle

Post by BoldAdventure » Mon Apr 15, 2019 11:53 am

If you're new to Hemi's and Ram there are a bunch of oddities that feel different, that are totally normal. I had some of these concerns when we first bought our 1500 back in 2015.
2015 Power Wagon Laramie - "ROCKLANDER"
[Build Thread] [Instagram] [Youtube]

Post Reply