Dead power outlet. Fuse is ok

If it's about Power Wagons, this is where it'll go.
Post Reply
LagunaH1
50_Posts
50_Posts
Posts: 237
Joined: Mon Aug 26, 2013 8:41 am

Dead power outlet. Fuse is ok

Post by LagunaH1 » Sat Mar 03, 2018 11:11 am

Hey guys,

The power outlet in the lower left side of the center, isn't working. If I've read the owner's manual correctly, it's protected by fuse F104. The fuse is fine, as is the enter armrest outlet which, supposedly, is protected by the same fuse.

So... Wiring...? Socket?

Not sure where to start
2016 RAM 2500 Power Wagon SLT
NR6E

DocPaulo
50_Posts
50_Posts
Posts: 103
Joined: Wed Dec 07, 2016 7:37 pm
Model Year: 2014

Re: Dead power outlet. Fuse is ok

Post by DocPaulo » Sat Mar 03, 2018 12:48 pm

Probably the inverter? Are we talking of the 110v outlet?
14 Laramie PowerWagon Desert Brown
Black 17 PW wheels with Falken AT3W 315/70/17
DIABLOSPORT T1000 canned tunes
Auxbeam 42 curved lightbar
Firestone airbags with daystar cradles
Maghytec transmission pan, carli front diff armor, rock crusher rear diff cover
Diamondback tonneau with crossbin
RANCHO 9000XL suspension
EMF ball joints
WhiteKnuckle sliders (on order)

LagunaH1
50_Posts
50_Posts
Posts: 237
Joined: Mon Aug 26, 2013 8:41 am

Re: Dead power outlet. Fuse is ok

Post by LagunaH1 » Sat Mar 03, 2018 1:32 pm

Sorry, I could have been more precise. It's the 12 volt "cigar lighter" power outlet that's dead. The one located on the left hand side nearest the driver's seat.
2016 RAM 2500 Power Wagon SLT
NR6E

User avatar
DamageWagon
1000_Posts
1000_Posts
Posts: 1769
Joined: Mon Oct 10, 2016 11:21 pm
Model Year: 2011

Re: Dead power outlet. Fuse is ok

Post by DamageWagon » Sun Mar 04, 2018 12:37 am

I lost the same one, and my 110v inverter and the in-console 12v plug. My issue was that the fuse pins in the TIPM (fuse box) has bad contact. I noticed when removing the fuses that one side grabbed firmly and one did not. The loose side, I bent a leg of the fuse and stuck it back in - they all work now! All the fuses were good but weren’t making good contact with the pins.

LagunaH1
50_Posts
50_Posts
Posts: 237
Joined: Mon Aug 26, 2013 8:41 am

Re: Dead power outlet. Fuse is ok

Post by LagunaH1 » Mon Mar 12, 2018 8:44 am

The funny part is, the 12v outlet in the armrest / console works just fine. I haven't tested the 110V outlet, guess I should :)

Thanks for the feedback guys
2016 RAM 2500 Power Wagon SLT
NR6E

User avatar
Low_Sky
500_Posts
500_Posts
Posts: 587
Joined: Fri May 01, 2015 5:12 pm
Model Year: 2014
Location: Eagle River, Alaska

Re: Dead power outlet. Fuse is ok

Post by Low_Sky » Mon Mar 12, 2018 10:01 pm

My 12V outlet just died and is exhibiting the same symptoms. Let me know if you figure this out, and I'll do the same. I haven't plugged anything into the 110V outlet, but F104 is in tact, the console 12V outlet works.
John
Alaska
2015 PW Laramie w/RamBox, 35"x12.50r17 Toyo C/Ts, custom rock sliders, PCP front/rear half-spiders, DOR steering brace, drinks Amsoil Kool-Aid, custom offroad pinstripes and extreme mud splash graphics

Post Reply